実験1

次のような、二つのネットワークを一台のルータで接続した単純なネットワー クを構築する実験を行います。

ネットワーク構成図

但し、これを実現するのに、ルータ一台の他、スイッチ一台、パソコン一台だ けを使用します。 そのため、VLAN、 Virtual Machine を活用します。

ネットワーク構成図

接続

まず、ルータ、スイッチ、PC を接続します。 ルータの FastEthernet0/0 をスイッチの FastEthernet0/6 に、 ルータの FastEthernet0/1 をスイッチの FastEthernet0/7 につなぎます。 PC をスイッチの FastEthernet0/8 につなぎます。 なお、アドレスを設定せずにルータ、スイッチを輪になるように接続すると、 802.1d のプロトコルにより、輪ができている状態を解消するために、一部のポート が停止します。 これは、アドレスを振りなおした後でポートを起動すれば使用できるようにな りますので、問題ありません。

また、ルータやスイッチを接続するためのシリアルケーブルを PC に接続しま す。 PC では Tera Term などの端末ソフトを起動します。

PCの設定

VLANの準備

Intel の最近のネットワーク用の IC にはノートパソコンに搭載されているも のでも VLAN 機能を持っています。 但し、 Windows に最初から搭載されているドライバーにはその機能がありま せんので、ドライバーをインストールする必要があります。 それは、Advanced Network Services という機能です。 http://downloadcenter.intel.com/Default.aspx?lang=jpn にアクセスし、 ネットワークアダプタと OS を選択して、 Advaneced Network Services が搭 載されているドライバーをインストールします。

これにより、ネットワークアダプタの「構成」ボタンにおいて、 VLAN タブが 有効になります。

VLANタブ

ここでは VLAN4 と VLAN5 を作成しておきます。 作成すると、 Windows にネットワークデバイスとして追加されます。 一方で、従来のネットワーク接続は失われますので注意が必要です。

VLAN のネットワークアダプタ

VLAN4 には 172.20.3.2/24, VLAN5 には 172.20.2.2/24 を設定します。

Virtual Machine

無料で Windows OS も動作する、Sun の Virtual Box を利用しました。 Windows XP Professional を 2 つ用意します。 それぞれ winxp1 と winxp2 と名前を付けます。

ネットワークは「ブリッジ接続」を選び、 winxp1 は VLAN4 のインターフェ イスに、 winxp2 は VLAN5 のインターフェイスに接続します。 そして、 winxp1 の IP アドレスを 172.20.3.3/24 に、デフォルトゲートウェイ を 172.20.3.1 に、 winxp2 の IP アドレスを 172.20.2.3/24 に、デフォル トゲートウェイを 172.20.2.1 に設定します。

Virtual Box の VLAN 接続

スイッチ Catalyst 3560 の設定

VLAN を使用するため、 802.1Q という規格を使います。 CISCO では、複数の VLAN を一本の線に乗せることをtrunkと呼ん でいます。 一方、他社では違う呼び方をしています。 802.1Q という規格では、複数の VLAN パケットを混ぜる際に、個々の識別の ために Ether パケットのフレームを拡張して VLAN 番号でタグ付けをします。 そのため、802.1Q の規格による VLAN を タグ付き VLAN と呼んだり、混ぜて送受するポートを タグ付きポート と呼んだりします。

設定はポート 6 が VLAN4, ポート 7 を VLAN5 とします。 そして、ポート 8 は dot1q 指定の trunc に指定し、VLAN4 と VLAN 5 を通 します。


configure terminal

vlan 4
exit

vlan 5
exit

interface fastethernet0/6
switchport mode access
switchport access vlan 4
exit

interface fastethernet0/7
switchport mode access
switchport access vlan 5
exit

interface fastethernet0/8
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk allowed vlan 4,5
end

スイッチの設定の確認は show vlanshow interfaces FastEthernet0/8 switchport などで確認します。

catalyst3560#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                                Fa0/5, Gi0/1
3    VLAN0003                         active
4    VLAN0004                         active    Fa0/6
5    VLAN0005                         active    Fa0/7
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
3    enet  100003     1500  -      -      -        -    -        0      0
4    enet  100004     1500  -      -      -        -    -        0      0
5    enet  100005     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 tr    101003     1500  -      -      -        -    -        0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trnet 101005     1500  -      -      -        ibm  -        0      0

Remote SPAN VLANs
------------------------------------------------------------------------------


Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------
catalyst3560#show interface FastEthernet 0/8 switchport
Name: Fa0/8
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 3 (VLAN0003)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: 4,5
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none

ルータの設定

この実験ではルータのフォワーディング機能を確認します。


configure terminal
interface FastEthernet0/0
ip address 172.20.3.1 255.255.255.0
no shutdown
exit
interface FastEthernet0/1
ip address 172.20.2.1 255.255.255.0
no shutdown
end

ここで、 no shutdown を指定しないと、接続時に停止したポートが有効にな りませんので注意が必要です。

設定を確認するには、 show ip route を打つことで、自動的にルー ティングテーブルに接続したポートが自動的に追加されていることが確認でき ます。

Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.20.0.0/24 is subnetted, 2 subnets
C       172.20.2.0 is directly connected, FastEthernet0/1
C       172.20.3.0 is directly connected, FastEthernet0/0

実験の意味と原理

このような設定において、 VPC1 から VPC2 へ ping を打つと、返事が返って きます。これは何故でしょう?

VPC1

VPC1 のルーティングテーブルは次の様になっています。

C:\Documents and Settings\sakamoto>route print
===========================================================================
Interface List
0x1 ........................... MS TCP Loopback interface
0x2 ...08 00 27 25 dd 70 ...... AMD PCNET Family PCI Ethernet Adapter - パケット
 スケジューラ ミニポート
===========================================================================
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0       172.20.3.1      172.20.3.3       20
        127.0.0.0        255.0.0.0        127.0.0.1       127.0.0.1       1
       172.20.3.0    255.255.255.0       172.20.3.3      172.20.3.3       20
       172.20.3.3  255.255.255.255        127.0.0.1       127.0.0.1       20
   172.20.255.255  255.255.255.255       172.20.3.3      172.20.3.3       20
        224.0.0.0        240.0.0.0       172.20.3.3      172.20.3.3       20
  255.255.255.255  255.255.255.255       172.20.3.3      172.20.3.3       1
Default Gateway:        172.20.3.1
===========================================================================
Persistent Routes:
  None

このうち本質的なのは次です。

Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0       172.20.3.1      172.20.3.3       20
       172.20.3.0    255.255.255.0       172.20.3.3      172.20.3.3       20

送信元 172.20.3.3、宛先 172.20.2.3 の ICMP エコーパケットがデフォルト ゲートウェイ172.20.3.1 に送られます。

ルータ

show ip route による出力は次の通りです。

Router# show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.20.0.0/24 is subnetted, 2 subnets
C       172.20.2.0 is directly connected, FastEthernet0/1
C       172.20.3.0 is directly connected, FastEthernet0/0
Router#

受け取った 172.20.2.3 宛のパケットに関しては、ルーティングテーブルに当 該ネットワークが存在するので、フォワーディングされます。

VPC2

ルータより、送信元 172.20.3.3、宛先 172.20.2.3 の ICMP エコーパケット が到達します。

その結果、送信元 172.20.2.3、宛先 172.20.3.3 の ICMP エコーリプライパ ケットが生成されます。 この時、VPC2 のルーティングテーブルは次の様になっています。

C:\Documents and Settings\sakamoto>route print
===========================================================================
Interface List
0x1 ........................... MS TCP Loopback interface
0x2 ...08 00 27 25 dd 70 ...... AMD PCNET Family PCI Ethernet Adapter - パケット
 スケジューラ ミニポート
===========================================================================
===========================================================================
Active Routes:
Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0       172.20.2.1      172.20.2.3       20
        127.0.0.0        255.0.0.0        127.0.0.1       127.0.0.1       1
       172.20.3.0    255.255.255.0       172.20.2.3      172.20.2.3       20
       172.20.3.3  255.255.255.255        127.0.0.1       127.0.0.1       20
   172.20.255.255  255.255.255.255       172.20.2.3      172.20.2.3       20
        224.0.0.0        240.0.0.0       172.20.2.3      172.20.2.3       20
  255.255.255.255  255.255.255.255       172.20.2.3      172.20.2.3       1
Default Gateway:        172.20.2.1
===========================================================================
Persistent Routes:
  None

このうち本質的なのは次です。

Network Destination        Netmask          Gateway       Interface  Metric
          0.0.0.0          0.0.0.0       172.20.2.1      172.20.2.3       20
       172.20.2.0    255.255.255.0       172.20.2.3      172.20.2.3       20

これにより、送信元 172.20.2.3、宛先 172.20.3.3 の ICMP エコーリプライ パケットがデフォルトゲートウェイ172.20.2.1 に送られます。

ルータ

show ip route による出力は先ほど同様に、次の通りです。

     172.20.0.0/24 is subnetted, 2 subnets
C       172.20.2.0 is directly connected, FastEthernet0/1
C       172.20.3.0 is directly connected, FastEthernet0/0

受け取った 172.20.3.3 宛のパケットに関しては、ルーティングテーブルに当 該ネットワークが存在するので、フォワーディングされます。

VPC1

以上のプロセスにより、 ICMPエコーリプライパケットが返ってきます。

まとめ

以上のシナリオにおいて、パケットの転送に用いられた情報は以下の通りです。

VPC1
デフォルトゲートウェイ
ルータ
インターフェイスに与えられた IP アドレスとネットマスクにより計算さ れたルーティングテーブルの情報
VPC2
デフォルトゲートウェイ

つまりルータ 1 台のみの状況においては、パソコンでデフォルトゲートウェ イを設定しておけば、ルータでルーティングを特に設定しなくてもパケットの 交換は可能なことがわかります。


坂本直志 <sakamoto@c.dendai.ac.jp>
東京電機大学工学部情報通信工学科